Bitcoin donations to: 1CE9UfWJcHBYkWPns7iqBqZgKhd5xfqEaM thanks!
Buy Bitcoins easily by clicking HERE!


Use coupon radiopreppers for 20% off on the above site.Become a Patron!

Author Topic: PRC320 - RT320 RECEPTION PROBLEM  (Read 529 times)

gianmo1995

  • Newbie
  • *
  • Posts: 1
  • SMeter: +0/-0
    • View Profile
PRC320 - RT320 RECEPTION PROBLEM
« on: December 13, 2018, 02:17:16 AM »
Hello everybody.
First of all, forgive me for my poor english.

Today I'm here to ask you help for a problem I have with my PRC320. I searched everywhere about it, but never heard of.

Well, my PRC works just fine. It turns on, speaker ok, ATU ok, fine reception, CW filters working, full power output.
As soon as i press the PTT it transmits, but when i release it, the PRC remains silent, not switching back to reception. It's like I'm still holding the ptt, but it don't output power (neither in SSB or CW). The only thing I can hear is a really low volume note (like the one you hear when the band selector switch is in the wrong position, but with a very low volume output).
To solve this situation I have to play with all switches, sometimes to turn more and more on and off the prc. After some switch-playing the PRC switches back to reception, but 9 times over 10, as soon as i try again to transmit, the problem pops out another time.

Has someone experienced this issue? Can someone help me?

Many thanks everyone, best 73's

Sam Smith

  • Newbie
  • *
  • Posts: 1
  • SMeter: +0/-0
    • View Profile
Re: PRC320 - RT320 RECEPTION PROBLEM
« Reply #1 on: December 13, 2018, 01:44:22 PM »
Your English is very understandable-No problem here! Sounds like the PTT Relay circuit may have issues. Do you have any schematics of this radio? If you are handy with a soldering iron you might want to heat it up-First, check with an ohm meter to see if you have any opens / shorts that should not be there and carefully remove shorts or poor solder joints which may look open or which reads higher than it should.

Take note of any burnt smells or signs of circuit damage.

You may want to clean the inside circuits with alcohol or a mild detergent soap - don't use anything with Bleach if the chassis is aluminium as it may react and damage your radio. (Use your judgement or test with a cotton swab first)

Check the wiring to see if that circuit may have an open in it or if that wire needs replacing.

Also, check to see if any switches may be dirty or damaged (Ceramic switches can be damaged if the radio has been dropped - especially on the shaft or the knob(s).

In your search a good visual inspection of the radio (inside and out) might provide some answers.

In summary:

1) Visually inspect the radio; any apparent damage? Cracked knobs or panels?

2) Take the whiff test and check for burnt smells.

3) Clean the inside with alcohol and or mild detergent soap - make sure you rinse with water or alcohol and get any trash out. Also, check for burnt traces or wires.

Trouble shoot using the schematic but use the rule of thumb that says: "If it ain't broke - don't fix it!"

ZERO the ohm-meter before you use it to avoid erroneous conclusions! Been there! Done that!

Ask for advise from hams who have experience with this or similar radios (This is a great place to start!)

Lastly, share your findings with us here - I know I'd like that - others might too!

Best wishes to you friend - 73!

 

Radio Preppers

Re: PRC320 - RT320 RECEPTION PROBLEM
« Reply #1 on: December 13, 2018, 01:44:22 PM »