Tube radio

Started by NWARadio, April 01, 2014, 06:39:47 pm

Previous topic - Next topic

raybiker73

I have a Heathkit HW-101 that contains approximately 4 billion tubes (or it seemed that way when I had to replace them), and heats the room up nicely.

NWARadio

I need to start saving to send mine off to be worked on. I've been advised to have the capacitors replaced and I can either attempt that myself or send it off to be done. I'm not sure I'm brave enough to do it myself.
So long, and thanks for all the fish

raybiker73

Quote from: cockpitbob on April 01, 2014, 08:04:40 pm
I have a Heathkit HW101 (100W all mode, all HF) that someone gave me.  It hasn't run in so many years the rubber drive belts are rock hard.  Some day when my leisure time reappears I'm going to bring it back to life.


Hey Bob, I have a couple extra drive belts for the 101, if you need a set, they're yours. Just send me a PM if you want them.

cockpitbob

Quote from: raybiker73 on April 06, 2014, 02:26:35 pm
Quote from: cockpitbob on April 01, 2014, 08:04:40 pm
I have a Heathkit HW101 (100W all mode, all HF) that someone gave me.  It hasn't run in so many years the rubber drive belts are rock hard.  Some day when my leisure time reappears I'm going to bring it back to life.


Hey Bob, I have a couple extra drive belts for the 101, if you need a set, they're yours. Just send me a PM if you want them.
Thanks for the offer Ray, but I bought a belt kit off eBay last winter when I thought I would have time for it.  I got as far as using a Variac to slowly bring up the power supply to re-form the electrolytics.  After 2 days I had it up to 100% and nothing when pow.  I haven't touched it since though :-\